Difference between revisions of "Nl:GRAMPS 3.0 Wiki Handleiding - Familiestambomen beheren"

From Gramps
Jump to: navigation, search
(Een nieuwe familiestamboom starten)
m (Exporteren naar het GEDCOM formaat)
 
(23 intermediate revisions by 2 users not shown)
Line 1: Line 1:
Now we turn to a detailed exploration of the day-to-day use of GRAMPS. In this Chapter we give a detailed overview of how you can manage your family trees, as well as share your data with other genealogists.
+
Nu gaan we naar een gedetailleerde verkenning van het dagelijks gebruik van GRAMPS. In dit gedeelte geven we een overzicht van hoe u uw familiestambomen kunt organiseren en uw gegevens te delen met andere genealogen.
 +
 
 +
{{man index/nl|Gramps 3.0 Wiki Manual - Main Window/nl|Gramps 3.0 Wiki Manual - Entering and Editing Data: Brief/nl}}
 +
 
  
 
{{grampsmanualcopyright}}
 
{{grampsmanualcopyright}}
Line 11: Line 14:
  
  
Om een nieuwe familiestamboom te starten kiest u ofwel ''' Familiestambomen ->Familiestambomen beheren ''' ofwel klik de knop {{man button|Familiestambomen}} in de werkbalk. Dit opent het venster familiestambomen.
+
Om een nieuwe familiestamboom te starten kiest u ofwel ''' Familiestambomen ->Familiestambomen beheren ''' ofwel klik de knop {{man button|Familiestambomen}} in de werkbalk.  
 +
 
 +
Dit opent het venster familiestambomen.
 +
 
  
  
  
  
 +
Selecteer de knop {{man button|Nieuw}} en GRAMPS zal een nieuwe item aan de lijst toevoegen.
  
Selecteer de knop {{man button|Nieuw}} en GRAMPS zal een nieuwe item aan de lijst toevoegen. Om de standaardnaam ''Family Tree1'' te veranderen, klikt u op de naam en voert een nieuwe naam in.
+
 
 +
 
 +
 
 +
Om de standaardnaam ''Family Tree1'' te veranderen, klikt u op de naam en voert een nieuwe naam in.
  
  
Line 27: Line 37:
  
  
Voor elke geopende familiestamboom wordt een icoon getoond in de kolom: {man label|Status}}. Kies de familiestamboom die u wilt openen en open het bestand  met de knop {{man button|Familiestamboom laden}}. Of u kan dubbelklikken op de gewenste stamboom.
+
Voor elke geopende familiestamboom wordt een icoon getoond in de kolom: {{man label|Status}}. Kies de familiestamboom die u wilt openen en open het bestand  met de knop {{man button|Familiestamboom laden}}. Of u kan dubbelklikken op de gewenste stamboom.
  
 
Op een onlangs geopende stamboom opnieuw te openen, kiest u ofwel ''' Familiestambomen ->Onlangs geopend ''' ofwel de pijl naar beneden die zich rechts van de knop {{man button|Familiestambomen}} bevindt. Vervolgens selecteert u de gewenste stamboom uit de lijst.
 
Op een onlangs geopende stamboom opnieuw te openen, kiest u ofwel ''' Familiestambomen ->Onlangs geopend ''' ofwel de pijl naar beneden die zich rechts van de knop {{man button|Familiestambomen}} bevindt. Vervolgens selecteert u de gewenste stamboom uit de lijst.
Line 46: Line 56:
 
Het bestand enkel openen en raadplegen zal het bestand echter niet veranderen. Als er echter veranderingen gebeurd zijn en die zijn niet geannuleerd voor het sluiten van het bestand, zal GRAMPS bij het afsluiten van het programma, de gegevens opslaan met mogelijk gegevensverlies tot gevolg.}}
 
Het bestand enkel openen en raadplegen zal het bestand echter niet veranderen. Als er echter veranderingen gebeurd zijn en die zijn niet geannuleerd voor het sluiten van het bestand, zal GRAMPS bij het afsluiten van het programma, de gegevens opslaan met mogelijk gegevensverlies tot gevolg.}}
  
== Deleting a Family Tree ==
+
== Een familiestamboom verwijderen ==
Select the family tree you want removed, and click the {{man button|Delete}} button.  
+
Selecteer de familiestamboom die u wenst te verwijderen en klik op de knop: {{man button|Verwijderen}}.  
  
This will '''completely''' remove the tree, with no possibility to retrieve the data. Consider taking a backup of your data by exporting to the GRAMPS XML format, and storing that file.
+
Dit zal de familiestamboom '''volledig''' verwijderen. U hebt geen mogelijkheid meer om de gegevens op te vragen. U kunt overwegen om een reservekopie van uw gegevens te nemen door uw gegevens te exporteren naar het GRAMPS XML-formaat en dit bestand vervolgens op te slaan.
  
== Een familistamboom herbenoemen ==
+
== Een familiestamboom herbenoemen ==
You can rename a Family Tree (or an archive of it) by selecting the tree you want to rename and clicking {{man button|Rename}}. You can also click on the name in the list of trees.  
+
U kunt een familiestamboom (of een archief) herbenoemen. Dit doet u door de stamboom te selecteren en op {{man label|Herbenoem}} te klikken.
  
In either case, you just type in the new name to have it take effect.
+
U kunt ook op de naam in de lijst van stambomen klikken.
 +
 
 +
In beide gevallen, geeft u gewoon de nieuwe naam in en de stamboom is herbenoemd.
  
 
== Een reservekopie van een familiestamboom maken ==
 
== Een reservekopie van een familiestamboom maken ==
The safest way to backup your GRAMPS Family Tree is to export to '''GRAMPS XML''' format (or '''GRAMPS Package''' to include items from your Gallery) and copy the resultant file to a safe place, preferably in a different building.
 
  
You can use the Archive feature to store snapshots of your tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.
+
De veiligste methode om een reservekopie te maken van uw familiestamboom is een export naar het '''GRAMPS-XML''' formaat (of het '''GRAMPS Pakket''' waar ook bestanden voor uw galerij worden opgeslagen). Vervolgens kopieert u de onstane bestand op een veilige plaats, liefst zelfs in een ander gebouw.
  
''For advanced users:'' each database is stored in its own subdirectory under ~/.gramps. A manual backup can be made by backing up this directory.
+
U kunt de archiefeigenschappen benutten om momentopnames te maken van uw familiestamboom. Deze momentopnamen kunnen gebruikt worden als eenvoudige reservekopieën. Ze zijn zeer handig om iets uit te proberen om dan later deze acties misschien te annuleren.
 +
Let echter op: deze methode is niet aangewezen om een normale reservekopie te maken. Deze methode overleeft een defect aan uw harde schijf niet, net zomin als de meeste van de andere rampen die bij een computersysteem kunnen voorkomen.
 +
 
 +
''Voor meer ervaren gebruikers:'' elk gegevensbestand wordt onder een eigen submap geplaast in de {{man label|/home/user/.gramps}} map. U kunt een manuele reservekopie maken door deze map te kopieren.
  
 
== Een familiestamboom archiveren ==
 
== Een familiestamboom archiveren ==
You can easily archive and timestamp family trees with GRAMPS built-in use of [http://www.gnu.org/software/rcs/ GNU Revision Control System] or ''RCS''. For this to be possible this utility must be installed on your computer.
 
  
To make an archive, first make sure the tree you wish to archive is open. Then select the open family tree, and click the {{man button|Archive}} button. The archive will be listed under the tree from which it was created. Archives can be deleted and renamed.
+
U kunt zeer eenvoudig familiestambomen archiveren en voorzien van een tijdstempel door gebruik te maken van [http://www.gnu.org/software/rcs/ GNU Revisie Controle Systeem] of ''RCS''.
 +
Dan moet u wel nakijken of dit programma op uw computer is geïnstalleerd. Het is een klein bestand: voor Ubuntu 8.04 is de versie 5.7-21.
 +
 
 +
Het GNU RCS systeem controleert de verscheidene bestandsrevisies. RCS automatiseert de opslag, het opnieuw terughalen, het bijhouden van een logboek, de identificatie en het samenvoegen van revisies. RCS is bruikbaar voor tekst die zeer vaak aangepast wordt, zoals in programmabestanden, documentatie, grafieken en brieven.
 +
 
 +
Om een archief aan te maken moet u eerst zeker stellen dat de familiestamboom geopend is. Selecteer vervolgens de geopende stamboom en klik op de {{man button|Archiveer}} knop. Het archief wordt nu getoond in de lijst, onder de oorspronkelijke stamboom. Archieven kunnen eveneens verwijderd en herbeneoemd worden.
  
 
== Een familiestamboom herstellen ==
 
== Een familiestamboom herstellen ==
 +
[[Image:Dbmanager04.png|350px|Left|Een versie kiezen om te herstellen]][[Image:Dbmanager05.png|350px|right|Herstelde versie]]
 +
 +
 +
 +
  
Simply highlight the archive you want to restore, and select the {{man button|Restore}} button.
 
  
[[Image:Dbmanager04.png|Selecting a version to restore]]
 
  
GRAMPS will transfer the archive into a new Family Tree. The Family Tree name is based on the original name and the archive name.
+
Dit kan eenvoudig door het archief te selecteren en dan op de {{man button|Herstellen}} knop te klikken.
  
[[Image:Dbmanager05.png|Restored version]]
 
  
== Een familistamboom ontgrendelen  ==
 
When GRAMPS opens a tree, it locks the tree, preventing you or anyone else opening it at the same time. A second copy of GRAMPS will be able to open another family tree, but the tree already open will appear with the lock icon, indicating you cannot open it. Closing the tree in the first copy of GRAMPS will make it available to be opened in the second copy.
 
  
If you could open the same Family Tree in two GRAMPS at once, it is likely your data would be damaged.
 
  
In the unlikely event of a crash of GRAMPS, the family tree will be left in a locked state. To unlock the tree, select the locked family tree, and click the {{man button|Unlock}} button that will be available. Only do this if you are sure no other copy of GRAMPS is using this family tree.
+
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
GRAMPS zal het archief importeren in een nieuwe familiestamboom. De naam van deze stamboom zal gebaseerd zijn op de originele naam en de archiefnaam.
 +
 
 +
== Een familiestamboom ontgrendelen  ==
 +
Wanneer GRAMPS een familiestamboom opent, wordt deze stamboom vergrendeld zodat niemand, ook uzelf, deze familiestamboom opnieuw zou openen.
 +
Een tweede versie van GRAMPS kan een familiestamboom openen, maar de familiestamboom die reeds geopend is, zal met een {{man label|slot}} icoon verschijnen zodat u weet dat u deze familiestamboom niet kunt openen. Door in de eerste GRAMPS-versie de stamboom te sluiten, wordt de familiestamboom in de tweede GRAMPS-versie opnieuw beschikbaar
 +
 
 +
Door eenzelfde familiestamboom in twee versies van GRAMPS te openen is de kans groot dat uw gegevens beschadigd worden.
 +
 
 +
 
 +
In het onwaarschijnlijke geval dat GRAMPS zou crashen, wordt de familiestamboom vergrendeld afgesloten. Om deze stamboom opnieuw toegankelijk te maken, selecteert u deze stamboom en klikt u op de knop {{man button|ontgrendelen}} die dan beschikbaar wordt.  
 +
Doe dit echter enkel indien u er zeker van bent dat geen andere GRAMPS-versie de familiestamboom momenteel gebruikt.
  
 
== Een beschadigde familiestamboom herstellen ==
 
== Een beschadigde familiestamboom herstellen ==
 +
[[Image:Dbmanager07.png|350px|thumb|Een stamboom herstellen]]
  
Should your Family Tree become damaged or corrupted in some way, GRAMPS' Family Tree Manager will display a red Error icon in the {{man label|Status}} column. To tell GRAMPS to attempt to repair the damage, select the Tree and then click the {{man button|Repair}} button. This will attempt to rebuild your tree from the backup files that are automatically created on exit.
+
Indien uw familiestamboom toch beschadigd werd, wordt een rood fouticoon getoond in de {{man label|Status}} kolom.
  
[[Image:Dbmanager07.png]]
 
  
== Saving Changes to Your Family Tree ==
+
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
Door op de {{man button|Herstellen}} knop te klikken zal, GRAMPS proberen de familiestamboom te herstellen.
 +
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
 
 +
De stamboom wordt opnieuw opgebouwd vanuit de reservekopieën die automatisch worden aangemaakt als het programma verlaten wordt.
 +
 
 +
== Aanpassingen opslaan ==
  
 
GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click {{man button|OK}} when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.
 
GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click {{man button|OK}} when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.
Line 97: Line 148:
 
You can undo changes you've made by selecting ''' Edit ->Undo '''. If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can using the {{man label|Undo History}} dialog available from the {{man label|Edit}} menu.
 
You can undo changes you've made by selecting ''' Edit ->Undo '''. If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can using the {{man label|Undo History}} dialog available from the {{man label|Edit}} menu.
  
If you want to return your Family Tree to the way it was when you opened it, select ''' File ->Abandon changes and quit ''' . (This is just like quitting without saving in other programs.)
+
If you want to return your Family Tree to the way it was when you opened it, select ''' Familiestambomen ->Abandon changes and quit ''' . (This is just like quitting without saving in other programs.)
  
 
If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import it into a new Family Tree. The ''GRAMPS XML database'' format is recommended for this purpose.
 
If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import it into a new Family Tree. The ''GRAMPS XML database'' format is recommended for this purpose.
Line 119: Line 170:
 
{{man note| Importing vs. opening |Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.}}
 
{{man note| Importing vs. opening |Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.}}
  
To import data, select ''' File ->Import ''' . The '''Import database''' dialog will open, asking you to specify the file you wish to import.
+
To import data, select ''' Familiestambomen ->Import ''' . The '''Import database''' dialog will open, asking you to specify the file you wish to import.
  
 
{{man warn| Data loss with some formats |It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.}}
 
{{man warn| Data loss with some formats |It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.}}
Line 127: Line 178:
 
*GRAMPS V2.x database (grdb): Prior to Version 3.0, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).  
 
*GRAMPS V2.x database (grdb): Prior to Version 3.0, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).  
  
*GRAMPS XML: The GRAMPS XML file was the default format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable. The GRAMPS XML database is created by exporting ( ''' Family Trees ->Export... ''' ) to that format.
+
*GRAMPS XML: The GRAMPS XML file was the default format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable. The GRAMPS XML database is created by exporting ( ''' Familiestambomen ->Export... ''' ) to that format.
  
*GRAMPS package: The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( ''' Family Trees ->Export... ''' ) data in that format.
+
*GRAMPS package: The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( ''' Familiestambomen ->Export... ''' ) data in that format.
  
 
If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.
 
If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.
Line 139: Line 190:
 
'''Wait to update manual:''' The exporter is undergoing a major rewrite.
 
'''Wait to update manual:''' The exporter is undergoing a major rewrite.
  
[[Image:Export-druid.png|right|thumb|150px|Fig.3.xx Export assistant: format selection]]
+
[[Image:Gedcom_exporteren.png|right|thumb|200px|Fig.3.xx Export assistent]]
  
 
Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS database (grdb), GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.
 
Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS database (grdb), GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.
Line 149: Line 200:
 
=== Exporteren naar het GEDCOM formaat ===
 
=== Exporteren naar het GEDCOM formaat ===
  
GRAMPS allows you to export a database into the common GEDCOM format. It provides options that allow you to fine tune your export (see [image:Gedcom-export.png]gedcom-export-fig'' ).
 
  
*Encoding: Since different languages use different characters, it is important to tell a GEDCOM file what character set is used. The two formats traditionally accepted are ASCII and ANSEL. Since all ASCII characters are valid ANSEL characters, GRAMPS does not provide an option for ASCII.
+
[[Image:Gedcom-export.png|right|thumb|250px|Fig.3.xx.Export assistant: GEDCOM options]]
  
Because ANSEL is not commonly used, some genealogy programs will accept ANSI (more commonly known as ISO-8859-1) and Unicode character sets. Only select ANSI or Unicode if you know any program that attempts to read the GEDCOM file will understand these character sets.
+
GRAMPS laat u toe om een gegevensbestand te exporteren naar het gekende GEDCOM-formaat. Er zijn verscheidene opties om uw export te verfijnen.
  
 
*Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
 
*Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  
 
*Target: While GEDCOM is a standard, not every program implements it in the same way. This can lead to data loss. GRAMPS can reduce the data loss in some cases. You can tell GRAMPS what program is the target, and GRAMPS will customize the exported file for that program. If your program is not listed, choose the "GEDCOM 5.5 Standard".
 
*Target: While GEDCOM is a standard, not every program implements it in the same way. This can lead to data loss. GRAMPS can reduce the data loss in some cases. You can tell GRAMPS what program is the target, and GRAMPS will customize the exported file for that program. If your program is not listed, choose the "GEDCOM 5.5 Standard".
 
*Copyright: Allows you to select a statement to describe your Copyright claim.
 
  
 
*Do not include records marked private: Check this box to prevent private records from being included in the exported file.
 
*Do not include records marked private: Check this box to prevent private records from being included in the exported file.
Line 170: Line 218:
  
 
This option allows specify where your image files are located. This is useful when you are transferring your GEDCOM file from one computer to another. It tells the program that is importing the data where your images are.
 
This option allows specify where your image files are located. This is useful when you are transferring your GEDCOM file from one computer to another. It tells the program that is importing the data where your images are.
 
[[Image:Gedcom-export.png|right|thumb|150px|Fig.3.xx.Export assistant: GEDCOM options]]
 
  
 
=== Exporteren naar GRAMPS formaten ===
 
=== Exporteren naar GRAMPS formaten ===
  
*GRAMPS database (grdb) export: Exporting to the GRAMPS native format will simply make a copy of your data under another name. Exporting to this format can also be useful if you have directly opened an XML or GEDCOM file and would like to save it as the grdb file.
+
{{man warn|Privacy Filters |It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.}}
  
 
*GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
 
*GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
Line 196: Line 242:
  
  
{{man index/nl|Gramps 3.0 Wiki Manual - Main Window/nl|Gramps 3.0 Wiki Manual - Entering and Editing Data: Brief}}
+
{{man index/nl|Gramps 3.0 Wiki Manual - Main Window/nl|Gramps 3.0 Wiki Manual - Entering and Editing Data: Brief/nl}}
  
  
[[Category:Documentation]]
+
[[Category:Nl:Documentatie|Familiestambomen beheren]]

Latest revision as of 12:34, 11 August 2009

Nu gaan we naar een gedetailleerde verkenning van het dagelijks gebruik van GRAMPS. In dit gedeelte geven we een overzicht van hoe u uw familiestambomen kunt organiseren en uw gegevens te delen met andere genealogen.

Vorige [[Gramps {{{3}}} Wiki Manual/nl| Index]] Volgende


Gnome-important.png Special copyright notice: All edits to this page need to be under two different copyright licenses:

These licenses allow the Gramps project to maximally use this wiki manual as free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the wiki which fall only under the GFDL license via external links (using the syntax: [https://www.gramps-project.org/...]), not via internal links.
Also, only use the known Typographical conventions



Een nieuwe familiestamboom starten

Fig 3.1: Familiestambomen beheren


Om een nieuwe familiestamboom te starten kiest u ofwel Familiestambomen ->Familiestambomen beheren ofwel klik de knop Familiestambomen in de werkbalk.

Dit opent het venster familiestambomen.



Selecteer de knop Nieuw en GRAMPS zal een nieuwe item aan de lijst toevoegen.



Om de standaardnaam Family Tree1 te veranderen, klikt u op de naam en voert een nieuwe naam in.


Vervolgens selecteert u de knop Laad familiestamboom om de nieuwe, lege familiestamboom te openen.

Een bestaande familiestamboom openen

Om een familiestamboom te openen, kiest u ofwel Familiestambomen ->Familiestambomen beheren ofwel klikt u op de knop Familiestambomen in de werkbalk. Het Family Tree Manager-venster wordt dan getoond en u krijgt een lijst te zien van alle familiestambomen die GRAMPS kent.


Voor elke geopende familiestamboom wordt een icoon getoond in de kolom: Status. Kies de familiestamboom die u wilt openen en open het bestand met de knop Familiestamboom laden. Of u kan dubbelklikken op de gewenste stamboom.

Op een onlangs geopende stamboom opnieuw te openen, kiest u ofwel Familiestambomen ->Onlangs geopend ofwel de pijl naar beneden die zich rechts van de knop Familiestambomen bevindt. Vervolgens selecteert u de gewenste stamboom uit de lijst.

Indien u geen schrijfrechten hebt voor een bepaalde familiestamboom, wordt het bestand enkel in de modus 'enkel lezen' geopend. Gegevens kunnen dan wel gelezen worden, maar niet veranderd. In de titelbalk van het venster zal, om deze modus aan te geven, de tekst (Enkel lezen) verschijnen.

Een XML-gegevensbestand of een GEDCOM-bestand openen

GRAMPS laat u toe om bepaalde gegevensbestanden die niet opgeslagen zijn in het GRAMPS-formaat, toch te openen. via een opdrachtregel.

TODO link to page explaining how. 

Dit kunnen zowel XML- als GEDCOM-bestanden zijn. Maar u moet beseffen dat, indien deze bestanden vrij groot zijn, er prestatieproblemen kunnen optreden. Bovendien is het zo dat wanneer uw computer crasht al uw gegevens kunnen beschadigd worden. Daarom is het normaal gezien veel beter om een nieuwe familiestamboom aan te maken en dan uw XML/GEDCOM-bestand hierin te importeren.

Gramps-notes.png
Gegevensbestanden openen

XML- en GEDCOM-gegevensbestanden vereisen dat alle gegevens in het computergeheugen aanwezig zijn en geen indexen bevatten. Het eigen GRAMPS-formaat is een gegevensbestand dat enkel de gegevens die nodig zijn in het geheugen behoudt. Dit heeft als voordeel dat voor een groot bestand de gegevens veel sneller toegankelijk zijn en het dus efficiënt is om geen XML/GEDCOM-formaat te gebruiken.

Gnome-important.png
Bewerken van GEDCOM-bestanden

Let op: sommige gegevens kunnen verloren gaan wanneer een GEDCOM-bestand geïmporteerd of geëxporteerd wordt in of uit GRAMPS.

Het bestand enkel openen en raadplegen zal het bestand echter niet veranderen. Als er echter veranderingen gebeurd zijn en die zijn niet geannuleerd voor het sluiten van het bestand, zal GRAMPS bij het afsluiten van het programma, de gegevens opslaan met mogelijk gegevensverlies tot gevolg.

Een familiestamboom verwijderen

Selecteer de familiestamboom die u wenst te verwijderen en klik op de knop: Verwijderen.

Dit zal de familiestamboom volledig verwijderen. U hebt geen mogelijkheid meer om de gegevens op te vragen. U kunt overwegen om een reservekopie van uw gegevens te nemen door uw gegevens te exporteren naar het GRAMPS XML-formaat en dit bestand vervolgens op te slaan.

Een familiestamboom herbenoemen

U kunt een familiestamboom (of een archief) herbenoemen. Dit doet u door de stamboom te selecteren en op Herbenoem te klikken.

U kunt ook op de naam in de lijst van stambomen klikken.

In beide gevallen, geeft u gewoon de nieuwe naam in en de stamboom is herbenoemd.

Een reservekopie van een familiestamboom maken

De veiligste methode om een reservekopie te maken van uw familiestamboom is een export naar het GRAMPS-XML formaat (of het GRAMPS Pakket waar ook bestanden voor uw galerij worden opgeslagen). Vervolgens kopieert u de onstane bestand op een veilige plaats, liefst zelfs in een ander gebouw.

U kunt de archiefeigenschappen benutten om momentopnames te maken van uw familiestamboom. Deze momentopnamen kunnen gebruikt worden als eenvoudige reservekopieën. Ze zijn zeer handig om iets uit te proberen om dan later deze acties misschien te annuleren. Let echter op: deze methode is niet aangewezen om een normale reservekopie te maken. Deze methode overleeft een defect aan uw harde schijf niet, net zomin als de meeste van de andere rampen die bij een computersysteem kunnen voorkomen.

Voor meer ervaren gebruikers: elk gegevensbestand wordt onder een eigen submap geplaast in de /home/user/.gramps map. U kunt een manuele reservekopie maken door deze map te kopieren.

Een familiestamboom archiveren

U kunt zeer eenvoudig familiestambomen archiveren en voorzien van een tijdstempel door gebruik te maken van GNU Revisie Controle Systeem of RCS. Dan moet u wel nakijken of dit programma op uw computer is geïnstalleerd. Het is een klein bestand: voor Ubuntu 8.04 is de versie 5.7-21.

Het GNU RCS systeem controleert de verscheidene bestandsrevisies. RCS automatiseert de opslag, het opnieuw terughalen, het bijhouden van een logboek, de identificatie en het samenvoegen van revisies. RCS is bruikbaar voor tekst die zeer vaak aangepast wordt, zoals in programmabestanden, documentatie, grafieken en brieven.

Om een archief aan te maken moet u eerst zeker stellen dat de familiestamboom geopend is. Selecteer vervolgens de geopende stamboom en klik op de Archiveer knop. Het archief wordt nu getoond in de lijst, onder de oorspronkelijke stamboom. Archieven kunnen eveneens verwijderd en herbeneoemd worden.

Een familiestamboom herstellen

Een versie kiezen om te herstellen

Herstelde versie




Dit kan eenvoudig door het archief te selecteren en dan op de Herstellen knop te klikken.






GRAMPS zal het archief importeren in een nieuwe familiestamboom. De naam van deze stamboom zal gebaseerd zijn op de originele naam en de archiefnaam.

Een familiestamboom ontgrendelen

Wanneer GRAMPS een familiestamboom opent, wordt deze stamboom vergrendeld zodat niemand, ook uzelf, deze familiestamboom opnieuw zou openen. Een tweede versie van GRAMPS kan een familiestamboom openen, maar de familiestamboom die reeds geopend is, zal met een slot icoon verschijnen zodat u weet dat u deze familiestamboom niet kunt openen. Door in de eerste GRAMPS-versie de stamboom te sluiten, wordt de familiestamboom in de tweede GRAMPS-versie opnieuw beschikbaar

Door eenzelfde familiestamboom in twee versies van GRAMPS te openen is de kans groot dat uw gegevens beschadigd worden.


In het onwaarschijnlijke geval dat GRAMPS zou crashen, wordt de familiestamboom vergrendeld afgesloten. Om deze stamboom opnieuw toegankelijk te maken, selecteert u deze stamboom en klikt u op de knop ontgrendelen die dan beschikbaar wordt. Doe dit echter enkel indien u er zeker van bent dat geen andere GRAMPS-versie de familiestamboom momenteel gebruikt.

Een beschadigde familiestamboom herstellen

Een stamboom herstellen

Indien uw familiestamboom toch beschadigd werd, wordt een rood fouticoon getoond in de Status kolom.





Door op de Herstellen knop te klikken zal, GRAMPS proberen de familiestamboom te herstellen.





De stamboom wordt opnieuw opgebouwd vanuit de reservekopieën die automatisch worden aangemaakt als het programma verlaten wordt.

Aanpassingen opslaan

GRAMPS saves your changes as soon as you apply them. This means, for example, that any time you click OK when using GRAMPS, your changes are immediately recorded and saved. There is no separate "save" command.

You can undo changes you've made by selecting Edit ->Undo . If you select this command repeatedly, your most recent changes will be undone one at a time. To roll back multiple commands at a time, you can using the Undo History dialog available from the Edit menu.

If you want to return your Family Tree to the way it was when you opened it, select Familiestambomen ->Abandon changes and quit . (This is just like quitting without saving in other programs.)

If you would like to save a copy of your Family Tree under a different name, you will need to export it and then import it into a new Family Tree. The GRAMPS XML database format is recommended for this purpose.

Gegevens importeren

Importing allows you to bring data from other genealogy programs into a GRAMPS database. Currently, GRAMPS can import data from the following formats:

GRAMPS V2.x database (.grdb file extension)

GEDCOM (.ged file extension)

GRAMPS XML (.gramps file extension)

GRAMPS package (.gpkg file extension)

GeneWeb (.gw file extension)

GRAMPS CSV Spreadsheet - comma separated values (.csv file extension)

Gramps-notes.png
Importing vs. opening

Please recognize that importing a database is different from opening a database. When you import, you are actually bringing data from one database into a GRAMPS database. When you open a file, you are editing your original file.

To import data, select Familiestambomen ->Import . The Import database dialog will open, asking you to specify the file you wish to import.

Gnome-important.png
Data loss with some formats

It is important to note that the importing process is not perfect for GEDCOM and GeneWeb databases. There is a chance that some of the data in these databases will not be imported into GRAMPS.

The GRAMPS V2.x database, GRAMPS XML, and GRAMPS package are all native GRAMPS formats. There is no risk of information loss when importing from or exporting to these formats.

  • GRAMPS V2.x database (grdb): Prior to Version 3.0, this native GRAMPS database format was a specific form of Berkeley database (BSDDB) with a special structure of data tables. This format was binary and architecture-dependent. It was very quick and efficient, but not generally portable across computers with different binary architecture (e.g. i386 vs. alpha).
  • GRAMPS XML: The GRAMPS XML file was the default format for older (pre 2.x) versions of GRAMPS. Unlike the grdb format, it is architecture independent and human-readable. The database may also have references to non-local (external) media objects, therefore it is not guaranteed to be completely portable. The GRAMPS XML database is created by exporting ( Familiestambomen ->Export... ) to that format.
  • GRAMPS package: The GRAMPS package is a compressed archive containing the GRAMPS XML file and all media objects (images, sound files, etc.) to which the database refers. Because it contains all the media objects, this format is completely portable. The GRAMPS package is created by exporting ( Familiestambomen ->Export... ) data in that format.

If you import information from another GRAMPS database or GRAMPS XML database, you will see the progress of the operation in the progress bar of GRAMPS' main window.

The GRAMPS CSV Spreadsheet format allows importing and exporting of a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.

Gegevens exporteren

Wait to update manual: The exporter is undergoing a major rewrite.

Fig.3.xx Export assistent

Exporting allows you to share any portion of your GRAMPS database with other researchers as well as to enable you to transfer your data to another computer. Currently, GRAMPS can export data to the following formats: GRAMPS database (grdb), GRAMPS XML, GEDCOM, GRAMPS package, Web Family Tree, GeneWeb, and GRAMPS CSV Spreadsheet formats.

Gramps-notes.png
Export is saving a copy

When you export, you are saving a copy of the currently opened database. Exporting creates another file with a copy of your data. Note that the database that remains opened in your GRAMPS window is NOT the file saved by your export. Additional editing of the currently opened database will not alter the copy produced by the export.

To export data, choose File ->Export . This will bring up the Export assistant. Its pages will guide you through the format selection (see export-druid-fig ), file selection, and format specific export options (see gedcom-export-fig ). After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can click the Back button and revise any selection, and then go forward to redo the export.

Exporteren naar het GEDCOM formaat

Fig.3.xx.Export assistant: GEDCOM options

GRAMPS laat u toe om een gegevensbestand te exporteren naar het gekende GEDCOM-formaat. Er zijn verscheidene opties om uw export te verfijnen.

  • Filter: The filter allows you to export a limited amount of data, based on the criteria you select.
  • Target: While GEDCOM is a standard, not every program implements it in the same way. This can lead to data loss. GRAMPS can reduce the data loss in some cases. You can tell GRAMPS what program is the target, and GRAMPS will customize the exported file for that program. If your program is not listed, choose the "GEDCOM 5.5 Standard".
  • Do not include records marked private: Check this box to prevent private records from being included in the exported file.
  • Restrict data on living people: Check this box to limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported GEDCOM file. If you choose this option, you will be given additional options to limit further the data on living people. For example, you can choose to substitute the word "Living" for the first name; you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. GRAMPS uses an advanced algorithm to try to determine if a person could still be alive. Remember, GRAMPS is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.

  • Reference images from path: Check this box to tell GRAMPS to use the specific path for your images when writing image references in GEDCOM.

This option allows specify where your image files are located. This is useful when you are transferring your GEDCOM file from one computer to another. It tells the program that is importing the data where your images are.

Exporteren naar GRAMPS formaten

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for GRAMPS XML backups.

  • GRAMPS XML database export: Exporting into GRAMPS XML format will produce a database compatible with the previous versions of GRAMPS. As XML is a text-based human-readable format, you may also use it to take a look at your data.
  • GRAMPS package export: Exporting to the GRAMPS package format will create a compressed file that contains the database and copies of all associated media files. This is useful if you want to move your database to another computer or to share it with someone.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

If a media file is not found during export, you will see the same Missing Media dialog you encounter with GEDCOM export.

Exporten naar andere formaten

  • Web Family Tree: Exporting to Web Family Tree will create a text file that can be used by the Web Family Tree program. Export options include filter selection and the ability to limit data on living people to that of their family ties.
  • vCalendar and vCard: Exporting to vCalendar or vCard will save information in a format used in many calendaring and addressbook applications, sometimes called PIM for Personal Information Manager.
  • GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for more information.


Vorige [[Gramps {{{3}}} Wiki Manual/nl| Index]] Volgende