Difference between revisions of "Download"

From Gramps
Jump to: navigation, search
m (See also: Add Github link)
m (Linux and BSD distributions)
 
(34 intermediate revisions by 6 users not shown)
Line 54: Line 54:
 
==== PortableApps.com ====
 
==== PortableApps.com ====
 
A [https://portableapps.com/apps/education/gramps_portable '''PortableApps''' version] will run from an external device without the requirement of installing on the OS drive. PortableApps installations are <b><i>not</i></b> for touchscreen-based mobile devices. They just allow the application to run from external storage, USB thumbdrives.
 
A [https://portableapps.com/apps/education/gramps_portable '''PortableApps''' version] will run from an external device without the requirement of installing on the OS drive. PortableApps installations are <b><i>not</i></b> for touchscreen-based mobile devices. They just allow the application to run from external storage, USB thumbdrives.
 
As of {{CURRENTDAYNAME}}, {{CURRENTDAY}} {{CURRENTMONTHNAMEGEN}} {{CURRENTYEAR}}, the most current Gramps release is the {{TEMPLATE:version}} version. 
 
  
 
You can download the '''{{Version_windows_portable}} Gramps Portable version''' from:
 
You can download the '''{{Version_windows_portable}} Gramps Portable version''' from:
Line 63: Line 61:
 
* [http://sourceforge.net/projects/portableapps/files/Gramps%20Portable/ GrampsPortable_3.4.9.paf.exe] (29.0 MB)  
 
* [http://sourceforge.net/projects/portableapps/files/Gramps%20Portable/ GrampsPortable_3.4.9.paf.exe] (29.0 MB)  
  
[http://portableapps.com/apps/education/gramps_portable Portable Gramps from PortableApps.com] includes all dependencies required for Windows. ''Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu.'' By Bart.S - '''[http://portableapps.com/blog/84601 Please report packaging issues to the author.]''' (2012-09-07)
+
[http://portableapps.com/apps/education/gramps_portable Portable Gramps from PortableApps.com] includes all dependencies required for Windows. ''Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu.'' '''[https://portableapps.com/forums/support/education Please report packaging issues here]'''
  
 
==== Chocolatey NuGet Package ====
 
==== Chocolatey NuGet Package ====
Line 101: Line 99:
 
Before downloading the ready-to-run stand-alone bundle: Use your '''earlier version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees to the hardy and portable [[#1|XML format<sup>1</sup>]]. Read the [[Mac OS X:Application package|before installation]] instructions.
 
Before downloading the ready-to-run stand-alone bundle: Use your '''earlier version of Gramps''' to [[How_to_make_a_backup#Gramps_version_3.3_and_later|backup]] your Family Trees to the hardy and portable [[#1|XML format<sup>1</sup>]]. Read the [[Mac OS X:Application package|before installation]] instructions.
  
Tested for compatibility with Apple macOS/Mac OS X versions 10.5 ([https://wikipedia.org/wiki/Mac_OS_X_Leopard Leopard]) through 11 ([https://wikipedia.org/wiki/MacOS_Big_Sur Big Sur]). ''Help determining your Operating System version can be found in the [https://support.apple.com/en-us/HT201260 HT201260 Apple Support article.]''
+
Tested for compatibility with Apple macOS/Mac OS X versions 10.13 ([https://en.wikipedia.org/wiki/MacOS_version_history#Version_10.13:_%22High_Sierra%22 High Sierra]) through 12 ([https://en.wikipedia.org/wiki/MacOS_version_history#Version_12:_%22Monterey%22 Monterey]). ''Help determining your Operating System version can be found in the [https://support.apple.com/en-us/HT201260 HT201260 Apple Support article.]''
  
 
<big>
 
<big>
Line 114: Line 112:
 
=== Alternative independent installation ===
 
=== Alternative independent installation ===
 
[[File:Gramps-release.png|left]]
 
[[File:Gramps-release.png|left]]
Alternatively, Gramps can also be installed on macOS using either the MacPorts or Homebrew package manager systems.
+
Alternatively, Gramps can also be built and installed on macOS using MacPorts.
  
 
{{-}}
 
{{-}}
Line 126: Line 124:
  
 
==== Homebrew ====
 
==== Homebrew ====
 +
 +
The macOS application bundle can also be installed via the Homebrew package manager as a cask. Note that this is *not* a Homebrew build, it is a repackaging of the same Gramps.app provided in the above dmg. It does not depend on or use any of the Homebrew-built libraries.
 +
 +
 
[https://wikipedia.org/wiki/Homebrew_(package_manager) Homebrew] is an open-source package manager for macOS (and Linux).  
 
[https://wikipedia.org/wiki/Homebrew_(package_manager) Homebrew] is an open-source package manager for macOS (and Linux).  
  
Line 153: Line 155:
 
|<!-- GUI Package manager -->Add/Remove Software
 
|<!-- GUI Package manager -->Add/Remove Software
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Debian 8 ("jessie")(old old old stable): Gramps 4.1.1<!-- Debian 8 EOL ~2020-06-30 https://wiki.debian.org/DebianReleases#Production_Releases / Extended Long Term Support until ~2022-06-30 -->
+
* Debian 10 ("buster") (old stable): Gramps 5.0.1 <!--  https://wiki.debian.org/LTS Debian LTS support for Debian 9 "buster from August 1st, 2022 to June 30th, 2024  -->
* Debian 9 ("stretch") (old old stable): Gramps 4.2.5
 
* Debian 9 ("stretch")([https://packages.debian.org/stretch-backports/gramps backports]): Gramps 5.0.1
 
* Debian 10 ("buster") (old stable): Gramps 5.0.1
 
 
* Debian 10 ("buster")([https://packages.debian.org/buster-backports/gramps backports]) (stable): Gramps 5.1.2
 
* Debian 10 ("buster")([https://packages.debian.org/buster-backports/gramps backports]) (stable): Gramps 5.1.2
 
* Debian 11 ("bullseye")(stable): Gramps 5.1.3
 
* Debian 11 ("bullseye")(stable): Gramps 5.1.3
* bookworm (testing): Gramps 5.1.4
+
* Debian 11 ("bullseye")([https://packages.debian.org/bullseye-backports/gramps backports]): Gramps 5.1.5
* [http://packages.debian.org/sid/gramps sid (unstable)]: Gramps 5.1.4
+
* bookworm (testing): Gramps 5.1.5
 +
* [http://packages.debian.org/sid/gramps sid (unstable)]: Gramps 5.1.5
 
|<!-- Notes              -->[http://packages.debian.org/search?keywords=gramps available versions]
 
|<!-- Notes              -->[http://packages.debian.org/search?keywords=gramps available versions]
 
|-
 
|-
Line 166: Line 166:
 
|<!-- GUI Package manager -->Software Centre
 
|<!-- GUI Package manager -->Software Centre
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Xenial (16.04 LTS): Gramps: 4.2.2
+
* Bionic Beaver (18.04 LTS): Gramps: 5.1.2
* Xenial (16.04 LTS): Gramps: 4.2.6 ([https://launchpad.net/~rosco2/+archive/ubuntu/backports Backport])
+
* Focal (20.04 LTS): Gramps: 5.1.3
* Bionic Beaver (18.04 LTS): Gramps: 5.0.0
+
* Hirsute (21.04): Gramps: 5.1.3
* Eoan (19.10): Gramps: 5.0.1
+
* Impish (21.10): Gramps: 5.1.4
* Focal (20.04 LTS): Gramps: 5.1.2
+
* Jammy (Development: 22.04): Gramps: 5.1.5
* Groovy Gorilla (Development: 20.10): Gramps: 5.1.3
 
 
|<!-- Notes              -->[http://packages.ubuntu.com/search?keywords=gramps&searchon=names available versions]/ (Also see: [https://launchpad.net/~rosco2/+archive/ubuntu/backports Backports])
 
|<!-- Notes              -->[http://packages.ubuntu.com/search?keywords=gramps&searchon=names available versions]/ (Also see: [https://launchpad.net/~rosco2/+archive/ubuntu/backports Backports])
 
|-
 
|-
Line 177: Line 176:
 
|<!-- GUI Package manager -->Software Manager
 
|<!-- GUI Package manager -->Software Manager
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* 18.x(Gramps 4.2.2~dfsg-1)
+
* 19.x(Gramps 4.2.8) <!-- EOL April 2023 -->
* 19.x(Gramps 4.2.8)
+
* 20.x(Gramps 5.1.2) <!-- EOL April 2025 -->
* 20.x(Gramps 5.1.2)
 
 
|<!-- Notes              -->
 
|<!-- Notes              -->
 
* Use the "Software Manager" to install a recent version.
 
* Use the "Software Manager" to install a recent version.
Line 188: Line 186:
 
|<!-- GUI Package manager -->Add/Remove Software (Gnome)<br>or<br>Software Management (KDE)
 
|<!-- GUI Package manager -->Add/Remove Software (Gnome)<br>or<br>Software Management (KDE)
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Rawhide (Gramps 5.1.4)
+
* Rawhide (Gramps 5.1.5)
* Fedora 33 (Gramps 5.1.4)
+
* Fedora 34 (Gramps 5.1.5)
* Fedora 34 (Gramps 5.1.4)
+
* Fedora 35 (Gramps 5.1.5)
* Fedora 35 (Gramps 5.1.4)
+
* Fedora 35 (Gramps 5.1.5)
 +
* Fedora 36 (Gramps 5.1.5)
 
|<!-- Notes              -->[https://koji.fedoraproject.org/koji/packageinfo?packageID=1969 available versions]
 
|<!-- Notes              -->[https://koji.fedoraproject.org/koji/packageinfo?packageID=1969 available versions]
 
|-
 
|-
Line 197: Line 196:
 
|<!-- GUI Package manager -->|[https://wiki.mageia.org/en/Installing_and_removing_software drakrpm (or rpmdrake)]
 
|<!-- GUI Package manager -->|[https://wiki.mageia.org/en/Installing_and_removing_software drakrpm (or rpmdrake)]
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Mageia [https://madb.mageia.org/package/show/name/gramps/release/cauldron/ Caulron]: Gramps 5.1.4
+
* Mageia [https://madb.mageia.org/package/show/name/gramps/release/cauldron/ Caulron]: Gramps 5.1.5
* Mageia 7.1: Gramps 5.0.1
+
* Mageia 8.0: Gramps 5.1.3
 
|<!-- Notes              -->[http://mageia.madb.org/package/show/name/gramps Mageia App Db - gramps]
 
|<!-- Notes              -->[http://mageia.madb.org/package/show/name/gramps Mageia App Db - gramps]
 
|-
 
|-
 
|<!-- Distribution        -->[[File:OpenSUSE-distribution-icon.png|32px]] '''[https://www.opensuse.org/ openSUSE]'''
 
|<!-- Distribution        -->[[File:OpenSUSE-distribution-icon.png|32px]] '''[https://www.opensuse.org/ openSUSE]'''
 
|<!-- GUI Package manager -->[https://en.opensuse.org/YaST_Software_Management YaST]
 
|<!-- GUI Package manager -->[https://en.opensuse.org/YaST_Software_Management YaST]
|<!-- Current versions    -->
+
|<!-- Current versions    --><!-- https://www.mageia.org/en/support/ -->
* openSUSE Tumbleweed: Gramps 5.1.4
+
* openSUSE Tumbleweed: Gramps 5.1.5
* openSUSE Leap 15.2: Gramps 4.2.8
+
* openSUSE Leap 15.3: Gramps 4.2.8 <!-- is expected to be maintained until end of November 2022 https://en.opensuse.org/Lifetime#openSUSE_Leap -->
* openSUSE Leap 15.1: Gramps 4.2.8
 
* openSUSE Leap 15.0: Gramps 4.2.8
 
 
|<!-- Notes              -->[https://software.opensuse.org/package/gramps available versions]<br>The most recent version can usually be installed from the 'openSUSE BuildService - GNOME:Apps' repository
 
|<!-- Notes              -->[https://software.opensuse.org/package/gramps available versions]<br>The most recent version can usually be installed from the 'openSUSE BuildService - GNOME:Apps' repository
 
|-
 
|-
Line 213: Line 210:
 
|<!-- GUI Package manager -->
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
 +
* 15.0: Gramps 5.1.2 - [https://slackbuilds.org/repository/15.0/misc/gramps/?search=gramps slackbuilds.org]
 +
* 14.2: Gramps 5.1.2 - [https://slackbuilds.org/repository/14.2/misc/gramps/?search=gramps slackbuilds.org]
 
* 14.2: Gramps 4.2.6
 
* 14.2: Gramps 4.2.6
* 14.2: Gramps 5.1.2 - [https://slackbuilds.org/repository/14.2/misc/gramps/?search=gramps slackbuilds.org]
 
 
* 14.1: Gramps 4.0.3
 
* 14.1: Gramps 4.0.3
 
|<!-- Notes              -->[https://pkgs.org/search/?q=gramps available versions]
 
|<!-- Notes              -->[https://pkgs.org/search/?q=gramps available versions]
Line 221: Line 219:
 
|<!-- GUI Package manager --> [https://wiki.archlinux.org/index.php/pacman pacman]
 
|<!-- GUI Package manager --> [https://wiki.archlinux.org/index.php/pacman pacman]
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* Gramps 5.1.4
+
* Gramps 5.1.5
 
|<!-- Notes              -->[https://www.archlinux.org/packages/community/any/gramps/ available versions]
 
|<!-- Notes              -->[https://www.archlinux.org/packages/community/any/gramps/ available versions]
 
|-
 
|-
Line 228: Line 226:
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
 
* Gramps 5.1.4
 
* Gramps 5.1.4
 +
* Gramps 5.1.5 (testing)
 
|<!-- Notes              -->[https://packages.gentoo.org/packages/app-misc/gramps available versions]
 
|<!-- Notes              -->[https://packages.gentoo.org/packages/app-misc/gramps available versions]
 
|-
 
|-
Line 233: Line 232:
 
|<!-- GUI Package manager -->
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* NetBSD: [http://pkgsrc.se/databases/gramps5 Gramps 5.1.2]
+
* NetBSD: [http://pkgsrc.se/databases/gramps5 Gramps 5.1.5]
 
|<!-- Notes              -->
 
|<!-- Notes              -->
 
|-
 
|-
Line 240: Line 239:
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
 
* FreeBSD: Gramps 4.2.8
 
* FreeBSD: Gramps 4.2.8
* [https://www.freshports.org/science/gramps/ FreshPorts: Gramps 5.1.4]
+
* [https://www.freshports.org/science/gramps/ FreshPorts: Gramps 5.1.5]
 
|<!-- Notes              --><!--[http://portsmon.freebsd.org/portoverview.py?category=science&portname=gramps available versions]-->
 
|<!-- Notes              --><!--[http://portsmon.freebsd.org/portoverview.py?category=science&portname=gramps available versions]-->
 
|-
 
|-
Line 246: Line 245:
 
|<!-- GUI Package manager -->
 
|<!-- GUI Package manager -->
 
|<!-- Current versions    -->
 
|<!-- Current versions    -->
* OpenBSD: Gramps 5.1.3
+
* OpenBSD: Gramps 5.1.5
 
|<!-- Notes              -->[http://openports.se/misc/gramps available versions]
 
|<!-- Notes              -->[http://openports.se/misc/gramps available versions]
 
|-
 
|-
Line 266: Line 265:
 
The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.
 
The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.
  
If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 3.4.3 to 3.4.4), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 2.y.z to 3.y.z), then the danger that it does not work properly is much greater.}}
+
If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 5.1.3 to 5.1.5), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 4.y.z to 5.y.z), then the danger that it does not work properly is much greater.}}
  
 
=== Debian-based ===
 
=== Debian-based ===
For [[File:Debianopenlogo-32.png|link=Download#Debian-based]]'''[[Debian|Debian-based linux distributions]]''' (Which includes [[File:Ubuntu_32x32.png|link=Download#Debian-based]]''' Ubuntu ''') <!--[{{github_url}}/releases/v5.1.3 Download the .deb file].-->[{{github_url}}/releases/v{{version}} Download the .deb file]. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved ({{man menu|change the filename to match the one you downloaded}}).
+
For [[File:Debianopenlogo-32.png|link=Download#Debian-based]]'''[[Debian|Debian-based linux distributions]]''' (Which includes [[File:Ubuntu_32x32.png|link=Download#Debian-based]]''' Ubuntu ''') <!--[{{github_url}}/releases/v5.1.5 Download the .deb file].-->[{{github_url}}/releases/download/v{{Version Linux Debian}}/gramps_{{Version Linux Debian}}-1_all.deb Download the .deb file]. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved ({{man menu|change the filename to match the one you downloaded}}).
  
 
  sudo dpkg -i gramps_{{version}}-1_all.deb
 
  sudo dpkg -i gramps_{{version}}-1_all.deb
Line 308: Line 307:
 
=== Flathub ===
 
=== Flathub ===
  
Gramps 5.1.4 is available in a flatpak at flathub.
+
Gramps {{Version Linux Flatpak}} is available as a Flatpak at Flathub.
  
{{man note|Please use your existing installation to backup your database before proceeding.|Also, it is a good idea to [[Gramps_5.1_Wiki_Manual_-_Manage_Family_Trees#Converting_a_BSDDB_Family_Tree_to_SQLite|convert your database to SQLite]] even though there is currently BSDDB3 support in the 5.1.4 flatpak.}}
+
{{man note|Please use your existing installation to backup your database before proceeding.|Also, it is a good idea to [[Gramps_5.1_Wiki_Manual_-_Manage_Family_Trees#Converting_a_BSDDB_Family_Tree_to_SQLite|convert your database to SQLite]] even though there is currently BSDDB3 support in the {{Version Linux Flatpak}} Flatpak.}}
  
First set up flatpak and the flathub repository on your system, there are instructions for various distributions at https://flatpak.org/setup/
+
First set up Flatpak and the Flathub repository on your system, there are instructions for various distributions at https://flatpak.org/setup/
  
Second, you can use the blue install button at https://flathub.org/apps/details/org.gramps_project.Gramps if you set your software manager up to work with flathub, or use the command below in a terminal for a system wide installation if you have sudo privileges:
+
Second, you can use the blue install button at https://flathub.org/apps/details/org.gramps_project.Gramps if you set your software manager up to work with Flathub, or use the command below in a terminal for a system wide installation if you have sudo privileges:
  
 
  flatpak install flathub org.gramps_project.Gramps
 
  flatpak install flathub org.gramps_project.Gramps
 +
  
 
{{-}}
 
{{-}}
Line 341: Line 341:
 
== Linux Live CD ==
 
== Linux Live CD ==
  
{{man warn|Note that both Live CD demonstrations use an old version of Gramps and it is not recommended for general use}}  
+
{{man warn|Note this '''Linux live CD Demonstration''' includes Gramps {{Version Linux Live CD}} an old version released 2010-11-17 and it is not recommended for general use}}  
  
 
[[File:Download_link.png|150px|left|link=https://sourceforge.net/projects/gramps/files/gramps-cdrom/lgenealogy-6.1-desktop-i386.iso/download]]
 
[[File:Download_link.png|150px|left|link=https://sourceforge.net/projects/gramps/files/gramps-cdrom/lgenealogy-6.1-desktop-i386.iso/download]]
'''Linux live CD Demonstration''' includes Gramps {{Version Linux Live CD}} pre-installed to trial, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn..). [[Linux_Genealogy_CD#Download_the_CD|Download the CD]] (727 MB). The [[Linux Genealogy CD|Linux Genealogy CD is based on Ubuntu 10.10 (Maverick Meerkat)]].  If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our [[Linux Genealogy CD]]. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install latest [http://www.ubuntulinux.org/ Ubuntu] and Gramps from the CD anytime you like.
+
'''Linux live CD Demonstration''' includes Gramps {{Version Linux Live CD}} pre-installed to trial, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn, [https://rufus.ie/en/ Rufus]..). [[Linux_Genealogy_CD#Download_the_CD|Download the CD]] (727 MB). The [[Linux Genealogy CD|Linux Genealogy CD is based on Ubuntu 10.10 (Maverick Meerkat)]].  If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our [[Linux Genealogy CD]]. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install latest [http://www.ubuntulinux.org/ Ubuntu] and Gramps from the CD anytime you like.
 
{{-}}
 
{{-}}
  
Line 364: Line 364:
 
* [https://github.com/gramps-project/gramps/releases GitHub folder of Gramps releases]
 
* [https://github.com/gramps-project/gramps/releases GitHub folder of Gramps releases]
 
* [[Previous releases of Gramps]]
 
* [[Previous releases of Gramps]]
 
+
* [[:Category:Versions|Versions on various platforms]]
  
 
[[Category:Documentation]]
 
[[Category:Documentation]]

Latest revision as of 06:06, 23 July 2022

Gramp-Small-background-wiki-2020.jpg

Research, organize and share your family tree with Gramps.

Gramps is a free software project and community. We strive to produce a genealogy program that is both intuitive for hobbyists and feature-complete for professional genealogists. It is a community project, created, developed and governed by genealogists.

Gramps-notes.png
Gramps Current version: 5.1.5 Released: 2022-02-05

Different data format to the GRAMPS 3.4 series. Full Python 3 support only as Python 2 support dropped. Uses GTK+ 3 GUI. Default database is now SQLite. Lot of updates see: What's new?
Linux 220x261.png Windows 180x160.png Macos 200x200.png Bsd daemon.png

Linux

Linux 220x261.png

Before upgrading your distribution: Use your earlier version of Gramps to backup your Family Trees to the hardy and portable XML format1.


via Distributions      via Flathub      Latest version (5.1.5) (advanced users only)

MS Windows

Windows 180x160.png

Before downloading the All-In-One software installer bundle for Windows: Use your earlier version of Gramps to backup your Family Trees to the hardy and portable XML format1.

This installer supports Microsoft Windows in all versions Vista/7 and later. The 64-bit versions of Windows allow more efficient access to more resources.

(Please note: Gramps prefers the Python-3.5 and Gtk-3.18 libraries and newer. Those libraries have dropped support for Windows XP. But Gramps can still be run on Windows XP with earlier library versions, i.e., Python3.4.4 and Gtk-3.16)

After download: double-click to install Gramps.
By default: new releases will be added in a new directory and earlier installations of Gramps will not be overwritten; the language will be a mix of British and US English.

Tango-Dialog-information.png
Shortcuts

During installation, one shortcut is placed on the desktop and two shortcuts are added the Start menu.
Please only use the 'console' secondary shortcut when performing diagnostics requested by a developer.
1) GrampsAIOXX 5.1.5 ← for normal use of Gramps
2)
GrampsAIOXX 5.1.5-console


Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. Should this fail for any reason, Create a new Family Tree and Import the back-up into this new Tree.

Use the Windows AIO (All-In-One) version, please use the download links above. For more information about individual versions, console and debug modes, release notes, etc., look at this page (English only). Or, you might want to look at the description of what is meant by an All In One Bundle.

Alternative independent installation

Gramps-release.png

If needed, there are alternatives to the All-In-One installer.

PortableApps.com

A PortableApps version will run from an external device without the requirement of installing on the OS drive. PortableApps installations are not for touchscreen-based mobile devices. They just allow the application to run from external storage, USB thumbdrives.

You can download the 5.1.5 Gramps Portable version from:

Note that PortableApps.com also has a Legacy 3.4.9 version of Gramps available -- although it is not recommended for general use; just for recovering older format databases.

Portable Gramps from PortableApps.com includes all dependencies required for Windows. Note:You can install it on C: then to run Gramps type C:\PortableApps\GrampsPortable\GrampsPortable.exe (Or the path you installed it to) or make a shortcut to that file on your desktop or start-menu. Please report packaging issues here

Chocolatey NuGet Package

You may also install using the alternative independent Gramps Chocolatey NuGet Package

Chocolatey NuGet is a Machine Package Manager, somewhat like apt-get, but built with Windows in mind.

Gramps for Windows with MSYS2

How to use MSYS2 to run latest Gramps development version from source in 64bit Windows.


Missing other languages

Microsoft Window Gramps AIO Installer Choose Components-Selection window.

The default Gramps AIO installer will embed the US dialect of English for the interface with the British spellcheck dictionary.

If you prefer a different language (or spell with the US or Australian dialects of English), please ensure that you pay special attention to the Choose Components phase of the installation.

To install a language other than English, select from both the Translations and Dictionaries during the Choose Components phase of the installation.

Even your primary language is installed by default, you might anticipate the need to spellcheck Notes in other than the British dialect of English. Be certain to select the appropriate languages from Dictionaries. Gramps will not access your Operating System's native dictionary.

There is no simple facility for adding interface or dictionary languages after installation.

macOS

Macos 200x200.png

Before downloading the ready-to-run stand-alone bundle: Use your earlier version of Gramps to backup your Family Trees to the hardy and portable XML format1. Read the before installation instructions.

Tested for compatibility with Apple macOS/Mac OS X versions 10.13 (High Sierra) through 12 (Monterey). Help determining your Operating System version can be found in the HT201260 Apple Support article.

After download: Double-click the .dmg file to mount the disk (note: your browser may do this for you automatically). Next, drag the Gramps application to your application folder and double-click to launch it. (For Apple Mac OS X, alternatively, you can click and hold on the disk icon at the top of the window of the mounted disk, and then option-drag to the Applications folder. This will create a new folder containing all the files, including the README and NEWS.)


Normally, when you try to load your old Family Tree you can allow it to be upgraded if necessary, and it will be opened. Should this fail for any reason, Create a new Family Tree and Import the back-up into this new Tree.

Alternative independent installation

Gramps-release.png

Alternatively, Gramps can also be built and installed on macOS using MacPorts.


MacPorts

MacPorts is a package manager for Apple Mac.


Homebrew

The macOS application bundle can also be installed via the Homebrew package manager as a cask. Note that this is *not* a Homebrew build, it is a repackaging of the same Gramps.app provided in the above dmg. It does not depend on or use any of the Homebrew-built libraries.


Homebrew is an open-source package manager for macOS (and Linux).

See https://github.com/homebrew/



Adding additional Spell Checking languages on macOS

Tango-Dialog-information.png

Gramps uses a different spell checker than the one provided by Mac OS X, with different spelling dictionary requirements. We can't easily provide dictionaries for all of the supported languages in the bundle, but they're easily downloaded from OpenOffice.org's website. Download the language you want and save it, then navigate to the download in Finder. Most browsers have a downloads window that offers "Show in Finder" in its context menu. Change the file extension from oxt to zip, then from the context menu select Open with... Archive Utility to decompress it. In the decompressed folder or perhaps in a subfolder you'll find the dictionary files in pairs, foo.aff and foo.dic. Some languages have more than one pair with a README file to explain why. Select a pair and copy it to /Library/Dictionaries (you'll have to authenticate with an administrator id and password), and if 'foo' isn't already a language or locale code, make it one. For example, the French package includes several pairs with names like fr-moderne.aff and fr-moderne.dic. The spell checker doesn't recognize those names, so when you copy them to /Library/Dictionaries you must rename them to fr.aff and fr.dic or fr_FR.aff and fr_FR.dic. You can have more than one dictionary pair installed if you use several languages, but one must match the language you use for Gramps or spell checking won't be enabled at all.



Linux and BSD distributions

Gramps-notes.png
These packages are built and supported by the distros.

If your distribution is not listed you may possibly find it listed on Repology
Please report any problems with them to the package maintainer.

Most Linux distributions come bundled with a version of Gramps, though it's not always the most recent version and it may not have been installed by default. Still it is recommended to use the Gramps version that comes with your distribution.

Below are ways to install Gramps on some of the more popular distributions:

Distribution GUI Package manager Current versions Notes
Debianopenlogo-32.png Debian Add/Remove Software
  • Debian 10 ("buster") (old stable): Gramps 5.0.1
  • Debian 10 ("buster")(backports) (stable): Gramps 5.1.2
  • Debian 11 ("bullseye")(stable): Gramps 5.1.3
  • Debian 11 ("bullseye")(backports): Gramps 5.1.5
  • bookworm (testing): Gramps 5.1.5
  • sid (unstable): Gramps 5.1.5
available versions
Ubuntu 32x32.png Ubuntu Software Centre
  • Bionic Beaver (18.04 LTS): Gramps: 5.1.2
  • Focal (20.04 LTS): Gramps: 5.1.3
  • Hirsute (21.04): Gramps: 5.1.3
  • Impish (21.10): Gramps: 5.1.4
  • Jammy (Development: 22.04): Gramps: 5.1.5
available versions/ (Also see: Backports)
Farm-Fresh linux mint.png Linux Mint Software Manager
  • 19.x(Gramps 4.2.8)
  • 20.x(Gramps 5.1.2)
Fedora 32x32.png Fedora Add/Remove Software (Gnome)
or
Software Management (KDE)
  • Rawhide (Gramps 5.1.5)
  • Fedora 34 (Gramps 5.1.5)
  • Fedora 35 (Gramps 5.1.5)
  • Fedora 35 (Gramps 5.1.5)
  • Fedora 36 (Gramps 5.1.5)
available versions
Mageia drakrpm (or rpmdrake)
  • Mageia Caulron: Gramps 5.1.5
  • Mageia 8.0: Gramps 5.1.3
Mageia App Db - gramps
OpenSUSE-distribution-icon.png openSUSE YaST
  • openSUSE Tumbleweed: Gramps 5.1.5
  • openSUSE Leap 15.3: Gramps 4.2.8
available versions
The most recent version can usually be installed from the 'openSUSE BuildService - GNOME:Apps' repository
Slackware-distribution-icon.jpg Slackware available versions
Archlinux-icon-crystal-32.svg Arch Linux pacman
  • Gramps 5.1.5
available versions
Gentoo-distribution-icon.pngGentoo Linux
  • Gramps 5.1.4
  • Gramps 5.1.5 (testing)
available versions
NetBSD
FreeBSD
OpenBSD
  • OpenBSD: Gramps 5.1.5
available versions



Linux: Install latest version

If your distribution doesn't ship with Gramps or you wish to install a different version than it ships with, you could try to install the latest version of Gramps manually.

Gnome-important.png
Warning before attempting this use your existing installation to make a Gramps XML backup

This should only be attempted by experienced users, and after you have backed up your Family Tree.

The version of Gramps that has been included in your distribution will have been tested to work with the components in that distribution. If you try to install a different version of Gramps there is a possibility that the components needed for the new version of Gramps are not available for your distribution, or they are available, but don't work properly. You might not discover that there is a problem till you have already done some work with the new version of Gramps.

If you already have Gramps installed, and you are only making a 'point' upgrade (i.e. from Gramps x.y.z to x.y.z+1, e.g. from 5.1.3 to 5.1.5), then it is likely but not certain that Gramps will continue to work. However, if the change is much greater, especially if it is a major version change (e.g. from 4.y.z to 5.y.z), then the danger that it does not work properly is much greater.

Debian-based

For Debianopenlogo-32.pngDebian-based linux distributions (Which includes Ubuntu 32x32.png Ubuntu ) Download the .deb file. Double-click on the downloaded .deb file or (for some distributions, e.g. Mint Debian) run the following command from the directory where the file was saved (change the filename to match the one you downloaded).

sudo dpkg -i gramps_5.1.5-1_all.deb

If you have an error about having unmet dependencies run:

sudo apt-get -f install

to install the dependencies.

If you see an error about an incomplete GTK installation and missing language translations when starting Gramps, run

sudo apt install language-pack-gnome-en

to install the proper language pack. You may need to replace 'en' with your own language code, like 'nl' for Dutch.

Useful command lines

Before upgrading you can[1]:

  • Find out what version you are running, by using this:
   dpkg-query -s gramps

that queries the package and gives you info about it.

  • If you are committed to an upgrade then make sure you have backed up you Family Trees to Gramps XML then run :
   sudo dpkg -r gramps

this will remove the current gramps package (assuming its a python3 version older versions could be python-gramps )

  • To stop Ubuntu updating gramps (to possibly an older version from Ubuntu!) you may need to run:
   sudo apt-mark hold gramps

Upgrade is then complete.

Flathub

Gramps 5.1.5-1 is available as a Flatpak at Flathub.

Gramps-notes.png
Please use your existing installation to backup your database before proceeding.

Also, it is a good idea to convert your database to SQLite even though there is currently BSDDB3 support in the 5.1.5-1 Flatpak.

First set up Flatpak and the Flathub repository on your system, there are instructions for various distributions at https://flatpak.org/setup/

Second, you can use the blue install button at https://flathub.org/apps/details/org.gramps_project.Gramps if you set your software manager up to work with Flathub, or use the command below in a terminal for a system wide installation if you have sudo privileges:

flatpak install flathub org.gramps_project.Gramps



For other distributions

For other distributions, Download link.png the source and follow the instructions for Linux:Build from source

BSD

Bsd daemon.png

Before upgrading your distribution: Use your old version of Gramps to backup your Family Trees [1].

via Distributions      Latest version (advanced users only)


See also:


Linux Live CD

Gnome-important.png
Note this Linux live CD Demonstration includes Gramps 3.2.5 an old version released 2010-11-17 and it is not recommended for general use

Download link.png

Linux live CD Demonstration includes Gramps 3.2.5 pre-installed to trial, without touching anything on the hard drive. To start this boot the Computer with this Live Linux Desktop on a CD in the CD/DVD-ROM Drive. (Requires that you write this image to a CD-ROM using CD-Burner software eg:Nero, Imgburn, Rufus..). Download the CD (727 MB). The Linux Genealogy CD is based on Ubuntu 10.10 (Maverick Meerkat). If you are interested in Gramps, but are afraid to actually install it or unable to install it (not your PC, windows, no internet at home, work laptop, ...), then try out our Linux Genealogy CD. It runs without installing on the hard disk and contains a collection of open source, free, genealogy programs. You can then install latest Ubuntu and Gramps from the CD anytime you like.

Online Demonstration

Gramps-notes.png
Note

This is a commercial limited trial and not endorsed by the Gramps-project. Beware of third parties having your genealogical data.

You can also try an online demonstration of Gramps on rollApp:

Select Launch Online then Test Drive(Opening/saving files will not be available)


Notes

[1] Backup to Gramps XML. You will find backup in the Family Tree menu of recent Gramps versions, otherwise use export in the same menu but uncheck privacy options in the Exporter Assistant in order to export all data. See : How to make a backup

See also